TransType Pro Bug?

albertoxic's picture

Hi,
I've just downloaded and installed TransType Pro 3.0.1 for Windows (trial version).

I'm using the software to fix some naming issues in T1 fonts.

In fact I'm performing a Win T1 --> Win T1 tranformation, editing family names, font name, etc.

The problem is that the resulting pfm files are (all) 1 KB so I suppose I'm losing kerning data in the tranformation...

Of course trial version has some limitations (50% of glyphs are modified and TrT logo is embedded) but this is probably a bug.

What do you think about it?

twardoch's picture

Alberto,

I can't replicate this behavior on the full version of TransType Pro 3.0.1 for Windows. The kerning pairs are present in the final PFM file.

Regards,
Adam Twardoch
Fontlab Ltd.

albertoxic's picture

Adam,
the Win T1 --> Win T1 tranformation is ok when the original T1 fonts have also inf and afm files. When they have only pfm and pfb files, TransType outputs only 1KB pfm files...
Regards
Alberto

yuri's picture

"No kerning" is a confirmed bug in TransType Pro 3.0.1. It will be fixed in 3.0.2, planned for release in a few days.

rjohnston's picture

While we're on the subject, I've had a few problems with font naming in TTPro. Conversions from PCT1 to MacT1 of Carter & Cone Galliard came out of TTPro weirdly named and apparently in the wrong suitcases (InDesign could only find a couple of the fonts -- a couple more it found, but couldn't find outline data for).

Screenshot 1: The original PCT1 fonts going into TTPro. Everything looks good in the conversion pane, all in the right place and properly named etc.

Screenshot 1

Screenshot 2: This is taking the output MacBinaries and plugging them straight into the front end of TTPro again. Everything's a bit of a mess on the left (reflected by the fonts' behaviour on the Mac).

Screenshot 2

I'm guessing this is to do with my lack of knowledge of naming schemes etc., but I'd appreciate any help.

FWIW, to get the job done I went back to ol' Crossfont, which handled everything quite happily.

Robert

(Sorry about the big jpegs)

twardoch's picture

Robert,

this clearly seems to be a case for the FontLab Support. Please go to http://www.fontlab.com/html/support.html and fill in the problem report form.

Adam

albertoxic's picture

Hi,
I've just visited the FontLab site and the MSN support forum.

There is no mention to this serious TransType Pro bug (missing kerning).

The trial version is still 3.0.1.

Did you correct this bug in the full version?

Many thanks

AR

twardoch's picture

Alberto,

we will be releasing 3.0.2 shortly.

Regards,
Adam Twardoch
Fontlab Ltd.

bvfonts's picture

I thought I would report what I think is a bug I found in TranType that I just purchased. I have a windows ttf that works fine in Mac OS X but after converting it into a mac ttf with Transtype it installs into the fontbook and then after I click another font and come back to it, it becomes greyed out and unselectable then it says OFF on it and after awhile dissapears from the menu altogether.

bvfonts's picture

I rebooted and retranstyped and it works fine now. I must of done something wrong but I don't know what.

Syndicate content Syndicate content