Problem in InDesign with OTF from Fontlab

vitalog's picture

I've got a strange problem trying to use OTF(CFF) fonts made in Fontlab 4.0; Everything looks good, all works but I can't apply "bold" or "italic" styles using hotkeys, only from font menu.
When I generated these fonts i used the Font Family Naming recommendations of Adam Twardoch (http://groups.msn.com/fontlab/tipsandtricks.msnw?action=get_message&mview=0&ID_Message=2843) but the problem remains.
Thank you

twardoch's picture

Vitaly,

please tell us which operating system you are using and which applications you are testing on. Even better, contact FontLab support* and provide us with the sample files. It's not really possible to answer hypothetically.

Regards,
Adam Twardoch
Fontlab Ltd.

*) http://www.fontlab.com/html/support.html

vitalog's picture

I use Windows XP pro, FontLab 4.04. OTF was generated from type 1 and tested on InDesign 3.0 under Windows XP and MacOS-X 10.3.7 Now I'll generate these OTF once again to post it as attachments.
But it seems strange that this problem never appeared before, because it apperaed with any settings and from any source fonts i used; and i thought that may be this feature (idesign hotkey support) simply requires some option that is not evident

Vitaly

twardoch's picture

Vitaly,

1. Do the hotkeys work in other OpenType fonts?

2. Have you set "Font is bold" and "Font is italic" in Font Info of the appropriate fonts?

3. Generally, I would recommend upgrading to FontLab 4.6 (or perhaps waiting until FontLab Studio 5.0 comes out and upgrading then). Since FontLab 4.04, quite a few things were fixed in FontLab's OpenType support.

Regards,
Adam Twardoch
Fontlab Ltd.

vitalog's picture

These hotkeys works with Adobe OpenType fonts that comes with InDesign. I've opened these fonts in FontLab looking for a differences with my fonts, but except Features in OpenType panel and some copyright and encodings info found nothing.

"Font is bold" and "font is italic" are set correctly.

Attachment removed

twardoch's picture

Vitaly,

Minion is a copyrighted font. Please do not post copyrighted works here that you are not the owner of. You are infringing other people's copyright (in this case, Adobe Systems.)

Adam

twardoch's picture

Moderator, please remove the post with the attachment.

Adam

vitalog's picture

Sorry, I took it only in experimental purposes. I will be more carefull in future

Vitaly

vitalog's picture

After some tests i found that this problem appears only when opening existing type 1 fonts. Creating a new font gives a good result. So it has no practical interest for me, but may be important for those font developer who convert his old type 1 fonts to open-type.

Thank you.

PS. Moderator, please remove my previous post with the attachment.

Vitaly

Miss Tiffany's picture

Apologies for the delay. Attachment Removed. In the future, for anyone listening, an email directly to me would help out as well.

Miss Tiffany's picture

And I also promise to pay closer attention. We shouldn't be uploading fonts to the server at all. If this needs to happen, perhaps the proper channel would be to e-mail someone directly with the files.

Syndicate content Syndicate content