.otf problem 10.4 Tiger vs. 10.6 Snow Leo

edmond1815's picture

Hi everyone,

I used FontLab Studio to add some special character to AGaramond font for example.
After that, exported to .otf Mac OS X.

The font it is ok in Freehand MX on 10.6 display correct, printing ok that special characters.
In Mac OS 10.4.11 same font, same file, same application, change the style, printing issues, etc.

What is the difference between 10.4 and 10.6 in this case?
Or how should i export a font to work normal in Freehand MX, display and printing correct.

Thank you for your patience,

Edmond

Thomas Phinney's picture

It might be helpful if you could be more specific about the problems you encountered. What kinds of printing issues?

twardoch's picture

For starters, in FontLab Studio / Preferences / Generating OpenType & TrueType / OpenType PS (.otf), disable "Use subroutines to compress..." and generate the font again. See if this fixed the problem.

edmond1815's picture

Thank you for your support!

@Thomas

The font should be converted to paths for printing. This only on 10.4 system.
In 10.6 it is ok.

@Twardoch

I disabled that.
I opened .otf font, and at the exporting i have an error in output window:

"[FATAL] aborting because of errors:
syntax error at "NULL"
[/Users/user/Library/Application Support/FontLab/Studio 5/Features/fontlab.fea 75]
ERROR: There was a problem while compiling OpenType font. Final .otf font is not saved. Please, check OpenType features definition for errors"

More specification:

For examaple the font "AmericanTypewriter" Bold and Medium.

In 10.4 looks just Medium style, whatever i choosed (Bold or Medium)
In 10.6 it is ok.

I cleanup font cash, etc, etc.

Thank you again,
Edmond

Syndicate content Syndicate content