Low accuracy between outlines and actual font

AmBonet's picture

Hello guys!

I am facing a strange font behavior. Let me sum it up- The glyph is slanted in the glyph cell. The thumbnail preview of the glyph is slanted. Until there, everything is fine. The problem starts when some glyphs appear upright in the Metrics window. Eventually, the .otf file carries these upright previews, whereas my outlines describe italic shapes!

I have been re-booting FontLab, cleaning up the glyph cells, re-inserting, etc, the problem is still here. Does is make any sense to you?
Many Thanks

johnych's picture

The Metrics window slants its preview according to the Slant angle field in Font Info > Key dimensions. And positive value slants to the left.
Surely this happens to all glyphs in the font.

Regards,
Johnych

AmBonet's picture

I omitted a detail. Most of the glyphs remain italic. Only few relate to the problem and it seems totally arbitrary.

@johnych
Thanks-
I just checked my font info, and the values are correct.

hrant's picture

Hi Amélie. Sounds like a bug. Which version of FontLab?

hhp

AmBonet's picture

Hi Hhp. I am using FontLab 5.0.2.
I didn't find a solution yet... Maybe the night will help me!

AmBonet's picture

After few try outs, I discovered the bug... It was hidden in the OT definition within the property window. For the given glyphs, switching their definition from Unassigned to Simple resolved the problem! EZ as Volt :)

johnych's picture

I'd recommend you to upgrade to 5.0.4 anyway just to have your kerning exported.

Regards,
Johnych

Syndicate content Syndicate content