Fontlab glyphs outline unresponsive

Core0's picture

I’m having a Fontlab 5.1 issue some of your old hats will probably laugh about. It seems so silly, but I cannot figure this out. Since yesterday the glyphs of my font project, the outlines, have become unresponsive to clicking on them. I cannot select the outline, activate points, nothing. I can select layers, I can turn them off and on, visibility and all. I can select glyphs in the map. I can write in both, preview and the metrics window. Everything else works, except for selecting an outline in any layer (in mask it doesn’t work either).

I looked for a secret lock I might have activated. The only lock in the bottom left corner of a glyphs window is for a different purpose. There doesn’t seem to be any feature that would prevent me from working with the outlines of glyphs, and yet I cannot touch my typeface again. What’s going on?

russellm's picture

did you accidentally lock the outline layer?

Core0's picture

Possibly—I thought about that too and looked everywhere, but I cannot find a way to lock or unlock it. The editing checkmark is inaccessible; it cannot be activated.

Core0's picture

Here is a screenshot of the layers box. The outline “eye” checkmark is dimmed, I can’t activate it. Yes, I am on Mac OS 10.10 beta (Yosemite), but I have been happily using Fontlab and edited fonts for two weeks since I installed it, without any glitch or incident. The OS version does not cause this sudden lockout.

http://cl.ly/image/013g2D2N0j3n

George Thomas's picture

Does this happen with all of your .vfb files?

If not, perhaps the permissions on the problem file have changed. Check that.

Core0's picture

Here is a screenshot with the right mouse-click active:
http://cl.ly/image/2M0y3V3Z3b3o

As you can see, none of the options is accessible. The lock in the lower left corner should change keyboard access, but unlocking/locking it does not seem to make any difference; I still can’t click or select the outline.

Core0's picture

Yes, it happens across the board with all vfb files.

Core0's picture

Permissions where? In the finder’s file system? That would be highly unlikely. I have not moved the file and it happend in the middle of editing. As if something got “turned on” in editing mode.

Core0's picture

I also tried restarting Fontlab, as well as restarting the entire system.

.00's picture

When strange things like this occur in FL the best thing to do is to trash Preferences as well as the Workspace file and do a system restart.

To access the preferences on OSX hold the Option key as you click on the GO menu to reveal the Library. In Library/Preferences/ find and trash: com.fontlab.studio5.plist

In that same Library go to Library/Application Support/FontLab/Studio5/Workspaces/ and trash: CurrentWorkspace51.rc

Core0's picture

James, your tip did the trick. Apparently Fontlab’s workspace and preferences were messed up. A bit annoying, now that I need to enter all preferences again. I don’t even remember all settings… But at least I can work with it again.

.00's picture

Glad to hear it. These files occasionally corrupt.
I just trash them on a monthly basis whether I have a problem or not!

Syndicate content Syndicate content